Do you have a requirement for specialised functionality built on concrete5?
I am available for hire at an hourly rate or can offer a fixed price against a well defined requirement.

Legacy marketplace closure. If you need to purchase one of my concrete5.6 addons after the closure of the legacy marketplace, please contact me through the respective addon support page "Get Help"  to purchase directly.

Pirate Speak

Translate your text to Pirate Speak. Installs a Pirate Speak text processor:

  • As a template for the Content Block
  • As a plugin for Universal Content Puller
  • As a concrete5 Helper (so developers can add Pirate Speak to anything)

Just set the Pirate Speak template for any content block and it will translate whatever is written in the block into Pirate Speak.

If you have Universal Content Puller, you can apply a Pirate Speak translation to content pulled from pretty much anywhere. The screengrabs are from a test page where I pulled the concrete5 About page and applied the Pirate Speak text processor.

Now includes magic data integration. If you want to apply pirate speak to other blocks, just write a new block template and call the Pirate Speak helper!

And now, translated:

Translate yer text t' Pirate Speak. Installs a Pirate Speak text processor:

  • As a template fer t' Conten' Block
  • As a plugin for Universal Conten' Haulin
  • As a cemen' foive Helper (so sea dogs can add Pirate Speak t' anythhin')

Just set t' Pirate Speak template fer any conten' block n it will translate whatever tis written in t' block into Pirate Speak.

If ye have Universal Conten' Haulin, ye can apply a Pirate Speak translation t' conten' hauled from pretty much anywhere. T' screengrabs are from a test sheet where Me, hauled t' cemen' foive About sheet n applied t' Pirate Speak text processor.

Now includes devils messin data integrashun. If ye wan t' apply pirate speak t' other blocks, just write a new block template n call t' Pirate Speak helper!

From version 1.2 this addon is compatible with php7. To update a site to php7 you will need to make core updates (at time of writing only on github and not released). You will also need to ensure that other addon packages are php7 compatible.

See more addons by JohntheFish.

Last updated: over a year ago